[Résolu] <br> ne va pas à la ligne.

Forum où sont déplacés les sujets résolus et les archives de l'entraide phpBB 3.3.x
Règles du forum
Forums des sujets résolus ou archivés de l'entraide phpBB 3.3.x
Les sujets restent ouverts, un certain temps, dans le but d'apporter des informations complémentaires, au besoin.
L'entraide n'est pas autorisée.
Message par Hervé »
Avatar du membre
Hervé Hervé
Messages : 248
Enregistré depuis : 2 ans 6 mois
Prénom : Rudy
Site internet : https://www.leforumrecifal.com/
Localisation : Jurbise - Belgique
Emploi : Retraité

<br> ne va pas à la ligne.

Message

Bonjour,
Les règles d'un de mes forums apparaissent comme ceci
Image
voici le code source : pourquoi les <br> ne donnent-ils pas lieu à une nouvelle ligne ?
Comment forcer les nouvelles lignes ?
Merci d'avance

Code : Tout sélectionner

			La présentation du nouveau MEMBRE est obligatoire avant de pouvoir accéder aux autres rubriques : <strong class="text-strong">en cas de non respect le sujet sera verrouillé.</strong>
<div class="forumbg forumbg-table tables1 null" style="width:98%"><div class="inner"><table class="table1">
	<tbody>
		<tr class="bg2">
			<td class="null" rowspan="1" colspan="1"><img src="https://www.leforumrecifal.com/images/You.png" class="postimage" alt="Image"></td>
			<td class="null" rowspan="1" colspan="1">Faisons connaissance, parlez-nous de <strong class="text-strong">VOUS</strong> : étudiant, retraité, dans quel domaine travaill(i)ez-vous ?<br>
<br>Vos centres d'intérêt : technique, écologie, environnement, ... ?<br>
<br>Comment êtes-vous venus au récifal ? Depuis combien de temps ?<br>
<br>De quelle région êtes-vous (vous pouvez indiquer votre position ici <a href="http://www.carte-des-membres.com/fr/leforumrecifal/" class="postlink">Carte des membres</a>) ?</td></tr>
	</tbody>
</table></div></div>
<strong class="text-strong">NE PARLEZ PAS ICI DE VOTRE BAC</strong> : vous aurez l'occasion de présenter votre (projet d') installation ici <a href="https://www.leforumrecifal.com/viewforum.php?f=7" class="postlink">viewforum.php?f=7</a><br>
Message par CAForum-bot »
Avatar du membre
CAForum-bot CAForum-bot
Messages : 157
Enregistré depuis : 3 ans

Re: <br> ne va pas à la ligne.

Message

:bangbang: Nous donnerons suite à ce sujet dans les plus brefs délais.


Merci de prendre note de ce formulaire de demande d'aide afin de détailler au mieux ce qui peut être utile pour cerner le problème.



Modèle de demande d'assistance


Quelle est la version de ton forum ?
Quelle est l'URL du forum concerné pour cette demande ?
Chez qui est hébergé le forum ?
Comment a été installé ce forum (avec le pack complet ou automatique) ?


Quelle est l'action la plus récente effectuée sur ce forum ?
Une inscription est-elle nécessaire pour reproduire ce problème ?
Est-ce que des extensions sont installées sur ce forum ?
Si oui, lesquelles ?


À partir de quelle version de phpBB3 la mise à jour a été faite ?
Quels styles sont installés sur le forum ?
Quelle est la langue par défaut du forum ?
Quel est la version de php du forum ?

Quelles mesures ont été prises (mise à jour du forum, installation d'une extension, d'un style, etc...) avant que ce problème ne devienne perceptible ?
Message par Fred »
Avatar du membre
Fred Fred
Messages : 2647
Enregistré depuis : 3 ans
Identité : Fred Rimbert
Site internet : https://caforum.fr
Localisation : Pays de la Loire
Intérêt : GitHub

Re: <br> ne va pas à la ligne.

Message

Salut
Remplace par ceci <br />

Cette forme vient du xhtml qui est la dernière norme des structures de pages web cette règle étant que toute balise doit être ouverte et toute balise doit être fermée.
Message par Hervé »
Avatar du membre
Hervé Hervé
Messages : 248
Enregistré depuis : 2 ans 6 mois
Prénom : Rudy
Site internet : https://www.leforumrecifal.com/
Localisation : Jurbise - Belgique
Emploi : Retraité

Re: <br> ne va pas à la ligne.

Message

Merci pour la réponse mais ce n'est pas moi qui ajoute <br>.
Voici comment la règle est encodée dans le PCA

Code : Tout sélectionner

La présentation du nouveau MEMBRE est obligatoire avant de pouvoir accéder aux autres rubriques : [b]en cas de non respect le sujet sera verrouillé.[/b]
[table=98,null]
	[tbody]
		[tr=bg2]
			[td=null,1,1][img]https://www.leforumrecifal.com/images/You.png[/img][/td]
			[td=null,1,1]Faisons connaissance, parlez-nous de [b]VOUS[/b] : étudiant, retraité, dans quel domaine travaill(i)ez-vous ?
Vos centres d'intérêt : technique, écologie, environnement, ... ?
Comment êtes-vous venus au récifal ? Depuis combien de temps ?
De quelle région êtes-vous (vous pouvez indiquer votre position ici [url=http://www.carte-des-membres.com/fr/leforumrecifal/]Carte des membres[/url]) ?[/td]
	[/tbody]
[/table]
[b]NE PARLEZ PAS ICI DE VOTRE BAC[/b] : vous aurez l'occasion de présenter votre (projet d') installation ici https://www.leforumrecifal.com/viewforum.php?f=7
Il n'y a pas de <br>, l'aperçu dans le PCA est correct

Image

les <br> sont bien ajoutés automatiquement (voir code source) et bien interprétés dans l'aperçu mais pas dans le forum
comment les transformer en <br /> ?

Edit : j'ai ajouté un BBcode qui ajoute <br />
maintenant à chaque ligne j'ai donc <br><br />
mais il n'y a toujours pas de nouvelle ligne dans le forum et le code source donne <br><br>
donc <br/> est trans formé en <br> !
Message par Fred »
Avatar du membre
Fred Fred
Messages : 2647
Enregistré depuis : 3 ans
Identité : Fred Rimbert
Site internet : https://caforum.fr
Localisation : Pays de la Loire
Intérêt : GitHub

Re: <br> ne va pas à la ligne.

Message

La balise <br /> se place en fin de phrase pour indiquer un retour à la ligne.
Message par Hervé »
Avatar du membre
Hervé Hervé
Messages : 248
Enregistré depuis : 2 ans 6 mois
Prénom : Rudy
Site internet : https://www.leforumrecifal.com/
Localisation : Jurbise - Belgique
Emploi : Retraité

Re: <br> ne va pas à la ligne.

Message

Dans le PCA j'écris

Code : Tout sélectionner

Vos centres d'intérêt : technique, écologie, environnement, ... ?[br]
le br entre crochets est un bbcode qui génère <br />
mais dansle code source de la page html je trouve

Code : Tout sélectionner

<br>Vos centres d'intérêt : technique, écologie, environnement, ... ?<br>
donc <br /> est transformé en <br> et il ne va pas à la ligne.
Message par Hervé »
Avatar du membre
Hervé Hervé
Messages : 248
Enregistré depuis : 2 ans 6 mois
Prénom : Rudy
Site internet : https://www.leforumrecifal.com/
Localisation : Jurbise - Belgique
Emploi : Retraité

Re: <br> ne va pas à la ligne.

Message

J'ai trouvé une autre solution.
J'avais utilisé une table pour que la petite image "Vous" soit à côté du texte et pas au-dessus.
J'ai fait autrement : j'ai défini un BBcode comme img mais avec l'attribut float, ça fonctionne.
Le problème initial en titre n'est pas résolu mais puisque j'ai trouvé un autre moyen de faire ce que je voulais ...
Message déplacé du forum Entraide phpBB 3.3.x vers le forum phpBB 3.3.x - Archives / Sujets résolus par Fred le 23 nov. 2020, 11:03

Partagez cette page
Twitter Whatsapp Linkedin Email
Vous devez être membre du forum pour répondre
Inscrivez-vous pour participer au forum ou Connecter-vous à votre compte.