Versions supportées

Informations sur les versions de PHP
Avatar du membre
Fred Fred
Fondateur
Messages: 3264
Enregistré depuis: 4 ans 4 mois
Identité: Fred Rimbert
Forum phpBB: https://caforum.fr
Localisation: Le Lude - Pays de la Loire
Intérêt: GitHub

Versions supportées

Message par Fred »

Chaque branche de version de PHP est entièrement prise en charge pendant deux ans à compter de sa version stable initiale. Au cours de cette période, les bogues et les problèmes de sécurité qui ont été signalés sont corrigés et sont publiés dans des versions ponctuelles régulières.

Après cette période de support actif de deux ans, chaque version est ensuite prise en charge pendant une année supplémentaire pour les problèmes de sécurité critiques uniquement. Les publications pendant cette période sont effectuées au besoin : il peut y avoir plusieurs versions ponctuelles, voire aucune, selon le nombre de rapports.

Une fois les trois années de prise en charge terminées, la version atteint sa fin de vie et n'est plus prise en charge.

Source

:white_check_mark: 8.3 : Première version 23 Nov 2023 | Support actif jusqu'au 23 Nov 2025 | Support de sécurité jusqu'au 23 Nov 2026
:white_check_mark: 8.2 : Première version 08 Dec 2022 | Support actif jusqu'au 08 Dec 2024 | Support de sécurité jusqu'au 08 Dec 2025
:white_check_mark: 8.1 : Première version 25 Nov 2021 | Support actif jusqu'au 25 Nov 2023 | Support de sécurité jusqu'au 25 Nov 2024 8.0 : Première version 26 Nov 2020 | Support actif jusqu'au 26 Nov 2022 | Support de sécurité jusqu'au 26 Nov 2023
7.4 : Première version 28 Nov 2019 | Support actif jusqu'au 28 Nov 2021 | Support de sécurité jusqu'au 28 Nov 2022
7.3 : Première version 06 Dec 2018 | Support actif jusqu'au 06 Dec 2020 | Support de sécurité jusqu'au 06 Dec 2021
7.2 : Première version 30 Nov 2017 | Support actif jusqu'au 30 Nov 2019 | Support de sécurité jusqu'au 30 nov 2020

Le langage PHP évolue régulièrement et lorsque vous utilisez une version de PHP qui n'est plus tenue à jour, vous exposez votre site Web à des risques de sécurité. Des personnes malveillantes pourraient par exemple exploiter des failles de sécurité connues pour s'introduire sur votre site et en modifier le contenu. Il est donc vivement recommandé de toujours utiliser une version récente de PHP.

3 statuts sont possibles :
  • la version de PHP est pleinement supportée : aucune action n'est requise
  • la version de PHP reçoit uniquement des mises à jour de sécurité : il est recommandé d'utiliser une version plus récente de PHP
  • la version de PHP n'est plus tenue à jour : il est vivement recommandé d'utiliser une version plus récente de PHP
Modifié en dernier par Fred le 24 nov. 2023, 08:26, modifié 4 fois.
Raison: Sortie de PHP 8.3