[Résolu] Privacy Policy non fonctionnel [3.1.0]

Entraide pour l'installation et l'exécution des forums en version
3.3.x

Règles du forum
Pensez à faire une recherche, afin de savoir si votre problème n'a pas déjà été traité.
[IMPORTANT] Merci de consulter le règlement de l'entraide

Merci de renseigner l'URL de votre forum dans vos informations de profil

Une fois le problème résolu, merci de passer votre sujet en [Résolu] en sélectionnant l'attribut en conséquence en bas de page.
Message par nexosenz »
Avatar du membre
nexosenz nexosenz
Messages: 43
Enregistré depuis: 1 an 1 mois
Forum phpBB: http://www.300Cpassion.com

Privacy Policy non fonctionnel [3.1.0]

Message

Bonjour

L'installation se passe très bien, mais elle ne fonctionne pas.

Le menu est bien créé dans l'onglet extension de l'acp, mais lorsque je clic sur "paramètres ..." ou "éditeur de fichier", et bien il ne ce passe rien, ca cherche dans le vide.

Mon forum est en 3.3.10 et cela est censé fonctionner.

Une idée ?
Message par Fred »
Avatar du membre
Fred Fred
Messages: 3142
Enregistré depuis: 4 ans 2 mois
Identité: Fred Rimbert
Forum phpBB: https://caforum.fr
Localisation: Le Lude - Pays de la Loire
Intérêt: GitHub

Re: Privacy Policy non fonctionnel [3.1.0]

Message

Dernier message de la page précédente:

Suite à une incompréhension de la règle des 5 jours je replace ce sujet dans l'entraide.

Ajouté 1 minute 58 secondes après :
Rappel de la dernière demande de vérification à faire sur ton forum
Fred a écrit: 12 févr. 2023, 12:52
Je désactiverais toutes les extensions et installerais l'extension de david63, et vérifier qu'elle est opérationnelle.
Message par nexosenz »
Avatar du membre
nexosenz nexosenz
Messages: 43
Enregistré depuis: 1 an 1 mois
Forum phpBB: http://www.300Cpassion.com

Re: Privacy Policy non fonctionnel [3.1.0]

Message

En effet ...

Donc revenons à nos montons. Nous en étions au fait que les liens dans l'acp ne fonctionnent pas, et que ca ne viens pas d'une incompatibilité avec une autre ext car même celles ci désactivées c'est pareil.

Ajouté 19 heures 43 secondes après :
Problème réglé !

Le souci venais de la partie de code de l'extension qui vérifie la version. le serveur distant ne répond pas ce qu'il fait que c'était très long a charger. En supprimant cette vérification tout est rentré dans l'ordre

Ajouté 21 minutes 27 secondes après :
Par contre, les 4 fichiers types sont en version anglaise malgré tout.

Sais tu s'il existe des fichiers types, qui peuvent servir de base à légèrement modifier en FR ?
Capture.PNG
Capture2.PNG
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Modifié en dernier par nexosenz le 17 févr. 2023, 15:21, modifié 1 fois. (Journal des éditions)
Message par Fred »
Avatar du membre
Fred Fred
Messages: 3142
Enregistré depuis: 4 ans 2 mois
Identité: Fred Rimbert
Forum phpBB: https://caforum.fr
Localisation: Le Lude - Pays de la Loire
Intérêt: GitHub

Re: Privacy Policy non fonctionnel [3.1.0]

Message

nexosenz a écrit: 18 févr. 2023, 10:42
Problème réglé !

Le souci venais de la partie de code de l'extension qui vérifie la version. le serveur distant ne répond pas ce qu'il fait que c'était très long a charger. En supprimant cette vérification tout est rentré dans l'ordre
Super mais il faut en dire plus sur ce que tu as fait pour débloquer la situation.
Quelle partie de code ?

Pour le reste, les sujets sur l'entraide correspondent à une seule demande pour un seul membre, voir cette règle
Message par nexosenz »
Avatar du membre
nexosenz nexosenz
Messages: 43
Enregistré depuis: 1 an 1 mois
Forum phpBB: http://www.300Cpassion.com

Re: Privacy Policy non fonctionnel [3.1.0]

Message

dans le fichier conposer.json

Cet appel à ce serveur répond en erreur 404. Il ne doit plus exister. j'ai supprimé toute la partie. D'ailleurs, il serait intéressant de regarder quel serveur est appelé sur la version de l'ext que tu utilises ici, vu que le pack de l'extension que j'utilise est celui que tu as mis ici en .zip.

Code: Tout sélectionner

 "version-check": {

         "host": "version.phpbbdev.space",

         "directory": "/versions",

         "filename": "privacy_policy_version_file.json",

 "ssl": false

     }
Message par Fred »
Avatar du membre
Fred Fred
Messages: 3142
Enregistré depuis: 4 ans 2 mois
Identité: Fred Rimbert
Forum phpBB: https://caforum.fr
Localisation: Le Lude - Pays de la Loire
Intérêt: GitHub

Re: Privacy Policy non fonctionnel [3.1.0]

Message

Merci de l'info, cependant ce code de vérification est bien présent dans le fichier composer.json de l'extension présente sur ce forum, sans que cela ne pose le moindre problème.
En test j'ai installé cette extension sur mon forum test, chez OVH, et c'est passé crème.

Bref super si cela fonctionne chez toi.

Ajouté 1 minute 24 secondes après :
Pour ton autre question, j'ai répondu ici pour la solution.
Partagez cette page
Twitter Whatsapp Linkedin Email
Vous devez être membre du forum pour répondre
Inscrivez-vous pour participer au forum ou Connecter-vous à votre compte.